issue in installing my own R package (possible problem with one of its dependencies)

gianmarco

TS Contributor
#1
Hello,
I have just found out that I cannot install my R package, which sits on GiHub.
C-like:
library(devtools)
install_github("gianmarcoalberti/CAinterprTools@v0.17")
When I try to install it, at first it seems that all is ok, and the various dependencies are loaded; then the procedure gets stuck and I get this message in the R console:
Code:
Error: package or namespace load failed for ‘RcmdrMisc’:
object ‘print.rcorr’ is not exported by 'namespace:Hmisc'
Error : package ‘RcmdrMisc’ could not be loaded
ERROR: lazy loading failed for package ‘CAinterprTools’
* removing ‘/Library/Frameworks/R.framework/Versions/3.4/Resources/library/CAinterprTools’
Installation failed: Command failed (1)
At the best of my understanding, the issue lies somewhere with the RcmdrMisc installation. Do you have any idea on how I can fix that?

Thanks
Best
Gm
 
Last edited: