tiff graphics device ignores case in file names

#1
I used the "tiff" function to save a graph to a file. I then wanted to create a second graph that was slightly different from the first one, and I indicated this by changing a single word in the file name from upper case to lower case. Specifically, I did this:

Code:
tiff(file = 'rDNA_Okazaki_Gros_et_al_2015_data_RAT1_37degrees_020819_1.tiff')

<code to plot something>

dev.off()


tiff(file = 'rDNA_Okazaki_Gros_et_al_2015_data_rat1_37degrees_020819_1.tiff')

<slightly different code to plot something slightly different>

dev.off()
Notice that the only difference between the two file names is "RAT" in the first and "rat" in the second. I was doing this in RStudio. I ran the first "<code to plot something>" first without sending it to a tiff file, and the graph appeared as expected in the RStudio plotting window. I then executed that code sending it to a tiff, and that went as expected. I then executed the "<slightly different code to plot something slightly different>" without sending it to a tiff, and it plotted the expected thing in the RStudio window. I then executed it to create the "rat" tiff, and it wasn't created - instead, a new "RAT" tiff was created with the slightly different plot was created. I tried this a few times and every time it would only create a file with the "RAT" name, and not the "rat" name. I executed the original plot and it recreated the first plot as it should have with the appropriate "RAT" name. Eventually, I changed the name of the "rat" file to "test.tiff", and then it correctly made the slightly different plot in a file called "test.tiff". It's as if the "tiff" function just could not understand the difference between "RAT" and "rat". Has anyone seen this kind of thing and, if so, does anyone know how to fix it?

Thanks.

Eric