Absolute Beginners Question: Problem with importing csv file

#1
Hello everyone,

I am just getting started on SAS, but cannot even get past the first step in my tutorial :(
Excel-Import does not work, so i am trying to import a .csv file.
It does import the data, the only problem is that instead of my dataset looking like this

var1 var2 var3
1 1 2812.658
2 0 1982.221

(each variable in one column)

it looks like this

var1_var2_var3
1;1;2812.658
2;0;1982.221

(only one column, variable names linked together with "_", values linked together with";")

any suggestions?

I know this is probably a stupid question, but I have not been able to get past this step in days (!), so I am growing a little frustrated...

Thanks a million in advance!

ets
 
#2
I just wanted to report that I have solved the problem. Apparently Excel on my computer saves .csv with semicolons as delimiters instead of commas. This seems to be common on many Windows versions in Germany / Benelux. If anyone else has this problem, just open the file with Notepad, automatically replace (Ctrl+H) the semicolons with commas and save again. Then you can import the file into SAS.

ets
 

Dason

Ambassador to the humans
#3
You can actually tell SAS that it is you're using for a delimiter. At least if you use proc import. I'd think there would be an option if you use the "import data" option from the file menu but there might not be. But I do know it's as easier as saying something like DLM = ";" in the import statement. I'm pretty sure that'd be the right syntax but I haven't had to worry about that for quite some time.