Stata technical problems


I am using Stata10 under Windows7 32-bit, and I have the following problem:
If I click on Edit/Preferences/Restore file associations I get the message 'Error resoring file associations'. Therefore I am not able to Choose Stata10 after Explore/Open with. However, from the Stata10 File/Open I can open the required file.
I will be very happy about your response.

Although I haven't had this exact problem myself, I've had a similar problem with a different program running on Windows 7. I solved the problem by opening the program using right-click and selecting "Run as administrator" rather than simply opening the program. Windows 7 will then ask you if you want to allow the program to make changes to the computer; click "yes". I hope this is helpful!

I run Stata10 as an administrator, despite I cannot open *.dta files by clicking on them, because it is not possible to choose Stata10 after Explore/Open with. I can find the exe application, but open with does not work. However, the file could be open from Stata.
Thank you for your help!